This page is best viewed with JavaScript enabled.
Montly Contest Winners
This page is best viewed with JavaScript enabled.

Go Back   The Gnomon Workshop Forums > Tutorials Discussions, Tips and Guidance > General Chat / Q+A


General Chat / Q+A Post your questions regarding Subscription, tutorials, etc.

Reply
 
Thread Tools Display Modes
Old 07-31-2009   #1
cdevens
Member
 
Join Date: Oct 2008
Location: Knoxville, TN
Posts: 67
Default Zbrush mapping problem

Hello,
My normal maps look fine in zbrush, but look horrible when I apply them in Maya.
I saw a thread with the same problem, but no solution was offered other than vertically flipping the normal map (which I have done). I have attached some images below that might give some insight into my problem. Any help would be greatly appreciated.

Render without normal map:


UV map (I know its sloppy, but this was only meant as a test, there are no overlapping uvs):


Normal Map:


Result in Maya with normal map:
cdevens is offline   Reply With Quote
Old 07-31-2009   #2
mkyboy
Member
 
Join Date: Feb 2007
Location: Sheffield, UK
Posts: 41

Awards Showcase

Default

Looks like the normalmap is being applied as a bumpmap.. find the node that links the texture [normalmap] to the shader in Hypershade.. Check to see if the option is set to Tangent Space and not Bump.

HTH

Cheers,
Chris
mkyboy is offline   Reply With Quote
Old 07-31-2009   #3
nicholas_caruana
Member
 
Join Date: Oct 2007
Location: Malta
Posts: 71

Awards Showcase

Default

for a normal map to work you must use mentalRay, or any other render that supports normal map.

not the maya software renderer
nicholas_caruana is offline   Reply With Quote
Old 07-31-2009   #4
cdevens
Member
 
Join Date: Oct 2008
Location: Knoxville, TN
Posts: 67
Default Problem Solved!

Thank you two very much. I had the map set to tangent space normal, but I was using the Maya software renderer. I didn't know that it didn't support normal maps, so it was just treating it as a bump map. I really appreciate the both of you taking the time to help!
cdevens is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bump mapping and ambient occlusion fatalerror General Chat / Q+A 2 01-13-2009 22:16 PM
Dare To Be Digital - Normal Mapping Problem Shawhir General Chat / Q+A 1 06-14-2008 19:52 PM
Need help with maya transparency mapping RCornell General Chat / Q+A 4 04-02-2007 12:40 PM


All times are GMT -7. The time now is 05:32 AM.

 
Forums Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
2000-2013 The Gnomon Workshop, Inc. - All Rights Reserved. No part of this website may be reproduced without written permission.